Hello, Groundbreaker!

Please use the feedback forum on this page the submit, upvote, downvote, and comment on bugs and suggestions created by you, the community. The Fire Hose team will use this tool to help prioritize your feedback.

Please Note: Before you create a new post, please take a moment to search and see if others have already covered the same topic.

Thank you for being here!

Clear all

[Solved] Technology Tree BUG on Xbox.

Topic starter

Hi, I just signed up for this forum to see if there were any other reports about an Xbox Technology Tree BUG. I'm often having problems scrolling up and down the Tech Tree to look at or unlock different techs. It will sometimes get stuck on the bottom lines that you've unlocked or up the top for higher tier techs. It will scroll left or right. But not up and down the Tech tree. I found it happens a lot, even on new games or on reload. I'm playing on an Xbox 1 X via Cloud Game Preview. I hope it can be fixed because I have been looking for a game like this on Xbox for years but could only find them on PC.

5 Answers

At first, I thought the interface was broken. But then I just kept hitting the D-pad and eventually discovered that you need to move enough to find a link back down. It is annoying, but I now just hit down and then up and that usually helps.

I believe the fix for this would be to have the interface scroll to display the currently selected item, so that it is always in view at the start.

Jaded1 Topic starter August 8, 2023 2:31 am

@chodaboy Yeah I have to push up, down, up till it gets me to the Tech Tree. But I've been finding when I am there sometimes it won't move up or down on the tree at all. But it will let me move left and right with the highlight box.

arctodus517 September 11, 2023 4:34 pm

@chodaboy This still doesn't mean it's not broken. Should be able to smoothly navigate the tree, without having to spam D-pad / bumpers.....


This is good feedback, passing along to the team and thank you! 

Jaded1 Topic starter August 8, 2023 1:42 pm

@laurenfhg Thank you, it tends to happen more when you get up to higher tier Technologies i.e. as you start unlocking the first blue level ones.


once again hate to give away stuff that shouldnt be a problem but many games long before this one had tech trees that worked perfectly so it makes me wonder how there could be any problems with this in  the first place but what you really need to do is probly scrap this tree and start from scratch  pick from the many functioning tech trees of other games and in essence copy and paste.        by the way still love the game despite massive amount of problems

another related problem is my tech tree seems to refresh everytime i load game and say all research including things i actively have researched is ready to be researched again 

LaurenFHG September 12, 2023 9:55 am

@trinzler are you still experiencing this with the 0.1.1 update?

also, copy/pasting a tech tree from another game isn't really a thing! i will say this seems to be a very localized bug, luckily.


Also, once it gets stuck, does anything un-stick it? Changing tabs, opening and closing the menu, etc?


When that happens I move to another Tab (RB or LB) and then once I get it scrolling go back to the tab I was originally trying to work with.